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Overview and Support  Services 

This chapter explains what is in this User Guide. It also describes the documentation standards 
used in the Guide and important customer support services. 

Chapter Contents 
 

What’s in this User Guide? 2

Documentation Standards 3

Customer Support Services 4

 



 

What’s in this User Guide? 
This Guide describes the MachineShop user interface and provides instructions on how to create 
and manage projects which use Interact applications.  

In the Guide, you will find the following chapters: 

Chapter Title Contents 

1 Overview and 
Support Services 

Guide contents, users, and 
Support Services. 

2 Introducing 
MachineShop 

Hardware and software 
requirements, navigation, 
help, and interface. 

3 Managing 
Projects 

Create, open, view and 
manage projects. 

4 Adding 
Connections 

File transfer setup and 
MachineShop Net 
connections 

5 Backing Up 
Projects 

Backup and restore local 
and remote projects 

6 Transferring 
Projects 

Transfer files to and from 
the runtime system 

7 Customizing 
MachineShop 

Options and Toolbar 

Appendix 
A 

MachineShop 
Dial-Up 
Networking 
Connections 

Create and configure 
connections in Windows 
95/98/NT 

Appendix 
B 

Cable Pinouts Pinouts for LAN, crossover 
and serial cables 
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Documentation Standards 
This Guide uses the following documentation standards: 

Style Type of Text 

Bold Important terms 

Courrier font Text to be entered from the keyboard. 

Note Alternative approaches or issues. 

Important Information to save time and minimize 
problems. 

Warning Information that will prevent equipment 
damage or persona injury. 

 

ISO Symbols 
This documentation uses the following caution symbols. 

Symbol Meaning 

 International Standards Organization 

(ISO) symbol for Caution 
(ISO 3864 No. B.3.1). Denotes activity 
that could affect operation of the 
computer if instructions are not 
followed. 

 PowerStation PS Series User Guide 
ISO symbol for Caution—risk of 

electrical shock (ISO 3864 
No B.3.6). Denotes activity that could 
cause personal injury from electrical 
shock or damage to equipment if 
instructions are not followed. 
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Customer Support Services 
We welcome your thoughts and suggestions on our products and services. You can contact us by 
telephone, email, or fax. You can also visit Parker EMN on the World Wide Web to learn the 
latest about our hardware, software, and customer support services. 

Telephone 707-584-7558 

Technical Support 707-584-7558 

E-mail emn_support@parker.com 

World Wide Web www.parkermotion.com

 

We recognize that every customer and every application have different support needs, so we offer 
four types of customer support services: 

• Technical Support 

• Training and New Business Development 

• Product Support Program 

• Documentation 

Technical Support 
The Technical Support department welcomes your questions as you develop or run your 
applications. We offer complimentary support for any customer, whether you are an end-user, 
original equipment manufacturer (OEM), system integrator, or distributor. 

If you have a question about MachineShop or Interact, be sure to complete the following steps: 

1. Check the Readme files installed with the software. These files provide general 
information about the release. 

2. Consult the appropriate documentation and other printed materials included with 
MachineShop and Interact. 

3.  Check the online help. MachineShop, Interact, and MachineLogic each have extensive 
online help facilities that cover all aspects of the product. 

If you cannot find a solution using one of the preceeding sources:  

1. Call your Parker products distributor for support. 

2. View the Technical Support web page at www.parkermotion.com. You’ll find answers to 
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Frequently Asked Questions, application notes, product user guides, and software 
downloads that may be helpful. 

3. Call Technical Support at 707-584-7558, 8:00 a.m. to 5:00 p.m., Eastern Time. 

You can call 1-800-C-Parker after hours for emergency assistance. 

Training and New Business Development 
Parker EMN supports all products through training programs, consulting services, and a Product 
Support Program.  

Training 
We offer training on all of our products, either at Parker EMN, in our state-of-the-art training 
center, or at your site. You can learn how to: 

• Write custom interfaces 

• Develop specialized applications 

• Implement your complete operator interface application 

To contact the Training Coordinator: 

Telephone  707-584-7559 

E-mail  
Emn_support@parker.com 

 

Documentation 
You can download Parker EMN product documentation from our Web site at 
www.parkermotion.com.  
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C h a p t e r  2  

Introducing MachineShop 

MachineShop is a suite of software products designed for machine control. The Suite includes 
three machine control programs: Interact, MachineLogic, and the MachineShop Toolbar. The 
MachineShop Toolbar provides a simple user interface for managing a machine profile or project. 
The machine control programs that are managed by the MachineShop Toolbar are modular and 
may be used independently of one another. 

This chapter describes the features of MachineShop and introduces you to the MachineShop 
Toolbar. It also describes the system requirements for the MachineShop development and runtime 
systems.  

Chapter Contents  
MachineShop Basics 7  

Development System Requirements 8

Runtime System Requirements 9

Getting Started with MachineShop 9

MachineShop User Interface 12
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MachineShop Basics 
MachineShop has a simple, easy-to-use interface for configuring and managing machine profiles 
or projects. Through the use of wizards for multi-step procedures and explorer-type windows for 
file management, MachineShop has simplified and automated the most common tasks associated 
with machine projects. 

MachineShop provides the necessary functionality to develop projects, including creating new 
projects, opening or backing up existing projects, launching various Suite programs, and 
transferring projects and files to and from runtime workstations such as PowerStations. 

The purpose of MachineShop is to perform the following operations: 

• Provide a central location for managing the development and runtime files for Interact.  

• Provide a simple user interface for transferring projects and their components to target 
runtime workstations such as PowerStations 

• Provide a simple user interface for backing up and restoring projects to/from runtime 
workstations or a variety of storage devices (diskette, Compact Flash, hard drive, network, 
etc.) 

• Provide a variety of communication options for transferring projects and performing backups, 
including serial, LAN, and disk connections 

The next section of this chapter will list the hardware and software requirements to run 
MachineShop. The remaining sections of the chapter will discuss working with security keys and 
getting started with MachineShop, including how to get help. 
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Development System Requirements 
The development system is the computer you will use to create and manage your MachineShop 
projects. Do not use the development system to run the projects that you create. Instead, transfer 
the projects to a workstation designated to run the projects.  

 Note Throughout this manual, we refer to a workstation that runs MachineShop projects as a 
runtime system.A runtime system is a Parker PowerStation designated to run the projects that 
you create. This manual assumes you are using a Parker PowerStation as your runtime 
system. Parker’s PowerStation products are the only currently supported runtime targets for 
Interact. 

Hardware Requirements 
Your development system must meet or exceed the following system requirements to run 
MachineShop as intended: 

• Processor: Pentium 133MHz / 300 MHz (Windows XP) 

• Memory: 24MB RAM (Windows 95/98 systems) 

• Memory: 32MB RAM (Windows NT systems) 

• Memory: 256MB RAM (Windows XP systems) 

• Fixed Storage: 50MB of free hard disk space 

• Removable Storage: CD-ROM drive 

• Input Devices: keyboard and Microsoft compatible mouse 

• Video: 800 x 600 resolution, 256 colors 

• 10 MB Ethernet network interface or serial port 

Software Requirements 
Your MachineShop development PC requires the following software in order to develop 
MachineShop projects: 

• Operating System: Windows 95 4.00.950B (OSR2),  
Windows 98, Windows 2000, Windows NT 4.0 SP3 or Windows XP 

• Interact: Version 6.0 or greater. 

Installing the Software 
Refer to the MachineShop Installation Booklet for step-by-step instructions on how to install 
MachineShop. 
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Runtime System Requirements 
The runtime system is the PowerStation designed to run your MachineShop projects. You will 
develop your projects on a development system and then download them to the runtime 
system.Use the runtime system to run projects only. All current model PowerStations come pre-
configured with an optimized configuration for Interact Version 7. 

 Note The development system is the PowerStation or Industrial PC that you use to create your 
projects.  

The runtime system requires MachineShop Shell to operate. MachineShop Shell is an easy-to-use 
interface that communicates with the MachineShop development machine. For more information 
on the MachineShop Shell, see the MachineShop Shell Runtime User Guide. 

Hardware and Software Requirements 

 Interact Version 7 runs on Parker’s PA and PA2 families of PowerStations. The PA and PA2family 
products are pre-configured to run Interact software. Interact is not available in a stand alone version for 
installation on 3rd party hardware. 

Installing the Software 
Refer to the MachineShop Installation Booklet for step-by-step instructions on how to install and 
setup the MachineShop software components. 

Getting Started with MachineShop 

Whether you are an experienced Interact Project Manager (IPM) user, or a new user, you should 
read this section before you begin to create and manage projects in MachineShop. This section 
explains how to read projects in MachineShop that were created in Interact Project Manager, how 
to get online help, and how to start MachineShop.  

Reading IPM Projects in MachineShop 
MachineShop was designed to replace Interact Project Manager (IPM); however, MachineShop is 
capable of reading projects that were created in IPM or Interact.  

 Note In order for MachineShop to read these projects, they must be located in the MachineShop 
Projects directory on your hard drive. See Chapter 3 for information about the Project 
Directory structure. 

In fact, MachineShop will prompt you whenever you attempt to open an Interact or 
MachineLogic project that was not created in MachineShop. MachineShop displays the following 
message: 
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Click yes to create the associated files. After MachineShop creates the associated files, you can 
use MachineShop to view and download all IPM projects to the PowerStation Shell. 

Important After you create the associated MachineShop files, you can still use IPM to download Interact 
projects to the PowerStation Shell, but you cannot use IPM to download Interact projects to 
the MachineShop Shell.  

MachineShop can also read project backups that you created in IPM. When you restore a project 
backup that was created with IPM, MachineShop maintains the directory structure for 
Interact projects. 

Online Help 
Online Help is available if you have any questions about how to perform a particular operation or 
need information about the elements appearing on the screen. To access the online help, simply 
select Help from the MachineShop Toolbar.  

There are several ways to find help in the MachineShop help file. You may view the help 
contents, perform an index search, or search for specific words or phrases using the Find tab in 
the help window. 

MachineShop also provides What’s This Help. What’s This Help provides information about 
different elements on the screen. To use the What’s This Help for a dialog box, click the question 
mark in the upper right-hand corner of the dialog box and then click the element to display a 
popup window. 

To use the What’s This Help for a menu command or toolbar button, click What’s This? on the 
Help menu, and then click the element to display a popup window. 

Starting MachineShop 
MachineShop is a Windows-based program designed to run in the Microsoft Windows 
environment. 

To start MachineShop, complete the following steps: 

1. Click Start on the Taskbar. 
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The Start menu opens. 

2. Select MachineShop from the Programs folder. 

The MachineShop folder opens. 

3. Click MachineShop Toolbar. 

 Note If you have a shortcut defined, double-click on the MachineShop Toolbar icon on your 
Windows desktop. 

The MachineShop Toolbar and Welcome dialog appear on your screen as shown below.  

 

 

 

 

 

 

 

 

 

 

The Welcome dialog is designed to guide you through the process of creating a project, opening 
an existing project, opening and downloading an existing project to the runtime system, and 
restoring a MachineShop project to the runtime system.  

The Welcome dialog will display on your screen each time you start MachineShop unless you 
select the Don’t display this startup screen again box. You may turn the Welcome dialog back 
on at anytime by selecting the Show welcome dialog on startup box in the Options dialog. 
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MachineShop User Interface 
The MachineShop user interface consists primarily of a toolbar that appears at the top of the 
Windows desktop by default. You can drag and drop the toolbar to any location on the screen.  

To drag the Toolbar to another location, complete the following steps: 

1. Position the mouse cursor over the MachineShop Toolbar. 

2. Click and drag the Toolbar to the desired screen location. 

You may also set the visibility of the toolbar using the Options command on the Tools menu. See 
Chapter 7 to learn how to set the visibility. 

Menus 

MachineShop provides conventional Windows menus that are used to gain access to the variety 
of functions available in MachineShop. The commands you will use most frequently are also 
displayed on the toolbar. 

File Menu 
The File menu allows you to create a new project, open an existing project, and close an open 
project. It also allows you to delete projects and define the location where MachineShop project 
information will be stored.  

Edit Menu 
Enabled with open projects, the Edit menu allows you to view or modify the description of the 
project, and set MachineLogic Memory and Ports, I/O interface, and Runtime Target for the 
current project. 

View Menu 
The View menu allows you to view information about the current project. Available information 
includes the project name, location, description, size, as well as information specific to projects 
that contain Interact and/or MachineLogic. It also allows you to view a list of runtime systems 
that are currently connected to the development system using a MachineShop Net LAN 
connection.  
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 Note MachineShop Net is a type of connection between development and runtime systems. 

Tools Menu 
The Tools menu allows you to create or restore backups for current projects or projects located on 
a remote system. It also allows you to customize and configure MachineShop. You may add, edit, 
or remove a suite component to MachineShop. When you add a suite component, MachineShop 
adds a button to the MachineShop Toolbar and a command to the Tools menu. Selecting either 
the command or the button launches the associated application. 

See Chapter 7 for a complete discussion on adding, editing, and removing suite components. 

Transfer Menu 
The Transfer menu is used to download a project (and project components) to or upload a project 
from a remote system. It is also used to select, add, edit, or remove the connections that will be 
used for transferring projects between MachineShop and a remote workstation. 

Window Menu 
The Window menu allows you to close Interact and Machine-Logic. 

Help Menu 
The Help menu includes the commands for finding help on MachineShop. This includes opening 
the help window, using the context-sensitive help, and connecting to the CTC Parker website. 
The Help menu also includes commands for viewing help for each of the I/O drivers supported by 
MachineLogic.  

Toolbars 
Toolbars provide quick access to the commands you use most often in MachineShop. The 
MachineShop Toolbar is comprised of three smaller toolbars called rebars. Rebars are individual 
segments of a toolbar. You can reposition the rebars within a toolbar by clicking and dragging the 
vertical line on the left side of the rebar to the desired location. 

The three rebars on the MachineShop Toolbar are: the Project Management Rebar, the Suite 
Navigation Rebar, and the Transfer Rebar. 
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Project Management Rebar 
Use the Project Management rebar to execute project-related commands that you would otherwise 
select from the MachineShop File, Tools, and Help menus.  

Suite Navigation Rebar 
Use the Suite Navigation Rebar to launch applications that you would otherwise launch from the 
MachineShop Tools menu or from the Windows Start menu. By default, Interact and 
MachineLogic are always available from this rebar if they were installed.  

When you open a MachineShop project, the selected program will launch with the proper 
application already loaded. After you launch Interact and MachineLogic, you can select the 
toolbar button to quickly switch back and forth between applications. 

You can easily add additional buttons to the Suite Navigation Rebar. See Chapter 7 for 
instructions on how to add and remove buttons. 

Transfer Rebar 
Use the Transfer Rebar to execute transfer-related commands that you would otherwise select 
from the MachineShop Transfer menu.  

MachineShop Toolbar 
Welcome to MachineShop dialog 
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C h a p t e r  3  

Managing Projects  

Once you become familiar with the user interface, you can begin creating and managing projects 
that use Interact applications and MachineLogic projects. This chapter will show you how to 
create a project, open and edit a project, and view project information. It also describes the 
directory structure of the MachineShop projects.  

Chapter Contents  
Overview of MachineShop Projects 16  

Create a New Project 18

Open an Existing Project 21

Save a Project 22

Delete a Project 22

View Project Information 23

Edit a Project 25
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Overview of MachineShop Projects  
A MachineShop project is a collection of related files and applications that you create on a 
development system and download to a runtime system. The purpose of a project is to group all 
the necessary files for HMI and special user defined startup programs for a machine control 
application together under a single name. You can create multiple projects on the development 
system to maintain various configurations of a runtime system’s tasks, but only one project can 
reside on a runtime system at one time. 

Creating a new project is very simple in MachineShop. MachineShop includes a New Project 
Wizard to guide you through the process of creating a project. Each project contains a specific set 
of files for running Interact applications and managing machine control programs. 

Project Directory Structure 
MachineShop stores all projects in the MachineShop subdirectory named Projects. Each project 
contains its own subdirectory. For example, Interact projects are created and stored in the 
\PROJECTS\INTERACT directory. 

The project directory structure is illustrated below: 
C:\MACHSHOP 
 \PROJECTS 
  \CONFIG 
   \INTERACT 
    \PROJ_1 
     \APPFILES 
     \STARTUP 
    \PROJ_2 
    \PROJ_3 
   \MACHLOG 
    \PROJ_1 
    \PROJ_3  
    \TUTORIAL 

The APPFILES directory stores subdirectories for each application you create for your Interact 
project, and the STARTUP directory stores extra AUTOEXEC.BAT files or driver system files, 
network initialization files, etc. 
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Startup Files 
Your runtime system may require its own set of startup files, such as the Autoexec.bat or 
Config.sys files, for loading system drivers or terminate-stay-resident programs (TSRs) into 
memory prior to running Interact. System drivers usually have a .sys extension. A command 
placed in the config.sys file loads the system drivers. A command in the Autoexec.bat file loads 
the TSRs. 

You can create your own startup files on the development system and copy these along with any 
needed programs, such as drivers or TSRs, into the project’s \STARTUP directory. During a 
project download, the development system will send these files to the runtime workstation. 

Setting the Project Path 
You may define the location where MachineShop projects will be stored by selecting the Project 
Path command from the File menu. This path is set to MACHSHOP\PROJECTS by default.  

 Note You cannot change the project path while a project is open in MachineShop.  

To change the project path, complete the following steps: 

1. Select the Project Path command from the File menu. 

The Project Path dialog box appears. 

 

 

 

 

2. Browse to the location on your hard drive where you want MachineShop to store project files. 

3. Click OK. 
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Create a New Project 
You are now ready to create a project. MachineShop provides a New Project Wizard to guide you 
through the process. 

To create a new project, complete the following steps: 

1. Select the New Project command from the File menu or click the New Project button in 
the toolbar. 

      The New Project dialog box appears. 

2. Enter the name of the project.  

      Enter a project description. 

3. Select the applications (Interact) that you want to use and its runtime target.  

            Click OK to accept these changes. 

4. The New Project Wizard appears.  

       Click Next, the following window appears.  

 

 

 

 

 

 

 

 

 

5. Enter a name eight characters or less and select the display resolution for your Interact 
application. 

 18 



 

6. Click Next to select the modules you want to use in your Interact application.  

7. The following window appears. 

 

 

 

 

 

 

 

 

 

8. Double-click the modules in the list that you want to use in your Interact application. 

9. Click Next to select the drivers you want to use in your Interact application. The 
following window appears. 

 

 

 

 

 

 

 

10. Double-click the drivers in the list that you want to use in your Interact application.  

11. Click Finish when you are finished selecting the drivers.  
The New Project Information dialog box appears with the options selected in the New 
Project Wizard. 
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12. Click OK to create the project using these options, or click Cancel to return to the last 
page of the New Project Wizard. 

13. Once the project is created, select the appropriate command from the Tools menu or click 
the appropriate button on the toolbar to launch MachineLogic or Interact. 

The program will open with the proper application ready for development. 
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Open an Existing Project 
Before developing your Interact application and/or MachineLogic project, you must open your 
project using the MachineShop Toolbar. Once the project is open, you can then launch Interact.  

 Note Project files use the .WMS extension. Each time you select the Open Project command, 
MachineShop searches the project directory for Interact application files that are not part of a 
MachineShop project. If files are found, MachineShop displays a message asking if you 
would like to create a MachineShop project file. 

To open a project, complete the following steps: 

1. Select the Open Project command from the File menu, or click the Open Project button on 
the toolbar. 

The Open Project dialog box appears. 

 

 

 

 

 

 

 

 

2. Browse to the location on your hard drive that contains the project file. 

Project files use the .WMS extension. 

3. Click Open to open the project. 

4. Select the appropriate command from the Tools menu or click the appropriate button on the 
toolbar to launch Interact or MachineLogic. 

The program will open with the proper application ready for development. 
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Save a Project 
You may save the current project to a local or network location. By default, the location is the 
current path setting set using the Project Path command. 

To save a project, complete the following steps: 

1. Select the Save Project As command from the File menu. 

The Save Project As dialog box appears. 

 

 

 

 

 

 

 

 

2. Browse to the location on your hard drive where you want to save the project. 

Project files use the .WMS extension. 

3. Enter the name of the project in the File name box. 

4. Click Save to save the project. 

Delete a Project 
You may delete any existing MachineShop project from any location using the Delete Project 
command. The Delete Project command also deletes the Interact files associated with the project 
as well as your startup files. 

To delete a project, complete the following steps: 

1. Close the project that you want to delete if it is open.  
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2. Select the Delete Project command from the File menu. 

The Delete Project dialog box appears.  

 

 

 

 

 

 

 

 

3. Browse to the location on your hard drive that contains the project you want to delete. 

Project files use the .WMS extension. 

4. Enter the name of the project in the File name box. 

5. Click Delete to delete the project. 

The Confirm Project Deletion dialog box appears. 

6. Click Yes to delete the project. 

View Project Information 
You may view information about the active project on your local system using the Project 
Information command. This includes startup files, Interact drivers and modules used, 
MachineLogic application information, and version numbers for Interact and MachineLogic 
development and runtime components. 

To view local project information, complete the following steps: 

1. Open the project if you haven’t already. 
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2. Select the Project Information command from the View menu or click the Project 
Information button on the toolbar. 

The Project Information property sheet appears.  

 

 

 

 

 

 

 

 

 

 

 

 

3. Click on one of the following tabs to view the available information for this project: 

• Project - Displays the name of the project, the location where this project is stored, the 
description, and the size of the individual components of this project. 

• Startup Files - Displays the names of the startup files (if any) located in the startup folder 
of this project. 

• Interact - Displays the names of the modules, drivers, and Interact applications used in 
this project. 

• Versions - Displays the version numbers for Interact and MachineLogic development and 
runtime components used by this project. 

 Note The Interact and MachineLogic tabs are available only when they are part of the project. 

4. Click OK or Cancel to close the Project Information property sheet. 
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Edit a Project 
You may edit the project description for the active project. If the project includes MachineLogic, 
you may use the Edit Menu - MachineLogic option to modify the I/O Interface, the Runtime 
Target, and the Memory and Ports assignment. 

Project Description Option 
Use the Project Description option on the Edit menu to view or modify the description for the 
current project. 

To modify the project description, complete the following steps: 

1. Open the project if you haven’t already. 

2. Select the Project Description command from the Edit menu. 

The Project Description dialog box appears. 

 

 

 

 

 

3. Enter or edit a description in the Project Description area. 

4. Click OK to accept the new or modified description, or Cancel to return to the previous 
description. 
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C h a p t e r  4  

Adding Connect ions 

Before you can transfer files to the runtime system, you must create a transfer connection in 
MachineShop. A connection refers to the method used to transfer files to or from a runtime 
system.  

MachineShop supports four methods for transferring files between a development system and a 
runtime system: MachineShop Net (LAN/Serial), disk, IPM Compatible (Serial), and Direct 
Serial.  

The MachineShop Network connection allows you to communicate with a runtime system using a 
Direct Serial cable, an IPM Compatible Serial cable, Ethernet Point-to-Point, or over a LAN.  

Multiple connections can be defined for different types of connections. Connections can even be 
defined with the same connection type, but for different target runtime systems.  

This chapter provides instructions on how to set up MachineShop Network Connections for a 
LAN, serial, Ethernet Point-to-Point, and MachineShop Direct Serial connection. It also describes 
how to add an IPM Compatible Serial and disk transfer connection. 

Chapter Contents  
MachineShop Direct Serial Communication 27  

MachineShop Net Connections 28

IPM Compatible Connection 44

Disk Transfer Connection 45
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MachineShop Direct Serial Communication 
Direct Serial communication supports communication between a development system and a 
runtime system that are connected to each other by a Null modem serial cable.  

The Direct Serial connection is designed to provide a simple method for users to transfer 
MachineShop project files from a development to a runtime system. It supports serial 
communications to the MachineShop Shell for projects including Interact or to the PowerStation 
Shell for projects developed in earlier versions Interact.  

PowerStation Shell serial communications use the same protocol as Interact Project Manager 
(IPM).  

To add a Direct Serial connection in MachineShop, complete the following steps: 

1. Open MachineShop. 

2. Select the Add Connection command from the Transfer Menu or click the Add Connection 
button on the toolbar. 

The New Connection dialog box appears. 

 

 

 

 

 

 

 

3. Select Direct Serial as the connection type. 

4. Enter a name for this connection. 

5. Click OK to accept these choices. 

The New Connection Wizard appears. 
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6. Select the COM port and baud rate you will be using in this connection. 

7. Click Finish to create the connection. 

MachineShop Net Connections 
MachineShop Net uses the TCP/IP protocol to communicate between a development system and 
a runtime system through a LAN, Dialup Networking, or a PPP serial connection. Parker chose 
this protocol because it is the primary communications protocol being used today. As its name 
implies, this is the same protocol that is the basis for Internet communications—email (SMTP), 
file transfer (FTP), and most notably, the World Wide Web (HTTP). 

While the Local Area Network (LAN) uses an Ethernet patch cable to connect a development 
system and a runtime system, Dialup Networking and PPP Serial uses a serial cable.  

Additionally, serial and modem connections require Dial-Up Networking, and an Ethernet point 
to point connection requires you to configure the Ethernet card’s TCP/IP properties. 

LAN communications are the preferred method of net communication because they offer the 
fastest transfer rates and the greatest flexibility.  

This section describes how to add MachineShop Net connections for a LAN, Ethernet point to 
point, serial, and modem connection. 

LAN Connection 
Using the MachineShop Net connection you can connect a development system to a runtime 
system through a Local Area Network (LAN). LAN communications are the preferred method of 
communication because they offer the fastest rates and the greatest flexibility. 
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To add a LAN connection in MachineShop, complete the following steps: 

1. Open MachineShop. 

2. Select the Add Connection command from the Transfer Menu or click the Add 
Connection button on the toolbar. 

      The New Connection dialog box appears. 

 

 

 

 

 

3. Enter a name for this connection. 

4. Select MachineShop Net (Serial/LAN) as the connection type. 

5. Click OK to accept these choices. 

6. The New Connection Wizard appears. 

 

 

 

 

 

 

 

7. Select LAN as the network connection type. 

8. Select Define runtime system now and then click Details to define the specific 
parameters for the target runtime system. 
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The Network Details dialog box appears.  

 

 

 

 

 

 

8.  Select one of the following options: 

• IP Address - Select this option to specify the IP address of a runtime system. Enter the IP 
address in the top box of the Name group. 

• MachineShop Net Name - Select this option to specify a runtime system by name. This is 
the name you entered using the MachineShop Shell/Settings/TCP/IP/Net Name 
command. 

MachineShop automatically displays the names that it is able to detect in the list box. 
Select a name from the list. 

 Note The runtime system must be configured and connected for it to appear in the MachineShop 
Net Name list. 

• Host Name - Select this option to specify the host name, such as 
www.Parkermotion.com, of the runtime system. This option requires a network with a 
domain name server (DNS). Your network administrator must also configure a host name 
to match the IP address of the runtime system prior to using this option. 

9. Click OK to accept these choices. 

You are returned to the New Connection Wizard. 

10. Click Next to continue. 

The following window appears. 
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11. Enter a user name and password only if an FTP user name and password was entered on the 
runtime system.  

The user name and password must match what was entered on the runtime system using the 
MachineShop Shell/Settings/FTP commands for you to gain access to the runtime system. 

12. Select Yes to enable passive transfers. Otherwise, select No.  

Passive transfers allow MachineShop to connect to an FTP server when the MachineShop 
Toolbar is behind a firewall. In most cases, you will NOT need passive transfers. 

13. Click Finish to create the connection. 

You are now ready to transfer projects that you create in MachineShop to a runtime system. See 
Chapter 3 for details on creating projects and Chapter 6 for details on transferring files. 

If you need to make changes to the connection simply select the Edit command from the Transfer 
menu.  

Ethernet Point to Point Connection 
Using the MachineShop Net connection you can connect a development system to a runtime 
system through an Ethernet patch cable. In addition to adding the connection in MachineShop, 
you must configure the TCP/IP properties for the Ethernet card.  

This section describes how to configure the TCP/IP properties and add the connection in 
MachineShop. For configuration in Windows NT, skip to Configure T. For configuration in 
Windows 2000, skip to Configure T. 

Configure TCP/IP Properties in Windows 95/98 
Use the Network option in the Windows Control Panel to configure the Ethernet card’s TCP/IP 
properties.  

 Note You may be asked to insert Windows installation disk(s) or CD-ROM after making the 
adjustment. 

To configure the TCP/IP properties in Windows 95/98, complete the following steps: 

1. Double-click the Network icon in the Windows Control Panel. 

The Network control property sheet appears. 
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2. Click the Configuration tab if it is not already in view. 

The Configuration tab appears. 

Select the TCP/IP network component for your Ethernet card from the list of components and 
then click Properties. 

The TCP/IP property sheet appears. 
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4. Click the IP Address tab if it is not already in view. 

The IP Address tab appears. 

5. Select Specify an IP Address and then enter the IP address and IP mask for the development 
system. 

PARKER recommends that you enter 10.0.0.1 as the IP address and 255.255.255.0 as the IP 
mask. 

 Note If you are using both serial and Ethernet point to point connections on the same development 
machine, you must have different IP addresses for each connection. 

6.     Click the Advanced tab. 

The Advanced tab appears. 

 

 

 

 

 

 

 

 

 

 

 

7. Select Set this protocol to be the default at the bottom of the screen. 

8. Click OK to accept these choices. 

The Network control property sheet appears. 

9. Click OK to exit the Network control property sheet. 

You are now ready to add the connection in MachineShop. See Add Connection in MachineShop  
on Add Connection in MachineShop  for instructions.  
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Configure TCP/IP Properties in Windows NT 
Use the Network option in the Windows Control Panel to configure the Ethernet card’s TCP/IP 
properties. 

To configure the TCP/IP properties in Windows NT, complete the following steps: 

1. Double-click the Network icon in the Windows Control Panel. 

The Network control property sheet appears. 

 

 

 

 

 

 

 

 

 

2. Click the Protocols tab. 

 

The Protocol tab appears. 
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3.  Select TCP/IP Protocol from the list of Network Protocols and then click Properties. 

The Microsoft TCP/IP property sheet appears. 

 

 

 

 

 

 

 

 

 

 

4. Click the IP Address tab if it is not already in view. 

The IP Address tab appears. 

5. Select the Ethernet adapter for your card from the list of adapters. 

6. Select Specify an IP address and then enter the IP address and IP mask for the development 
system. 

PARKER recommends that you enter 10.0.0.1 as the IP address and 255.255.255.0 as the IP 
mask. 

 Note If you are using both serial and Ethernet point to point connections on the same development 
machine, you must have different IP addresses for each connection. 

7. Click OK to accept these choices. 

The Network control property sheet appears. 
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8. Click OK to exit the Network property sheet. 

You are now ready to add the connection in MachineShop. Please skip to Add Connection in 
MachineShop . 

Configure TCP/IP Properties in Windows 2000 
Use the Network and Dial-Up Connections option in the Windows Control Panel to configure the 
Ethernet card’s TCP/IP properties.  

 Note You may be asked to insert Windows installation disk(s) or CD-ROM after making the 
adjustment. 

To configure the TCP/IP properties in Windows 2000, complete the following steps: 

1. Double-click the My Computer icon on the desktop and then double-click the Control 
Panel folder and then double-click the Network and Dial-Up Connections folder. 

2. Right-click the Local Area Connection and then select Properties. 

The Local Area Connection Properties sheet appears. 

 

 

 

 

 

 

 

Select Internet Protocol and click on Properties. 

The Internet Protocol Properties window appears: 
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4. Select Use the following IP Address and then enter the IP address and IP mask for the 
development system. 

Parker recommends that you enter 10.0.0.1 as the IP address and 255.255.255.0 as the IP 
mask. 

 Note If you are using both serial and Ethernet point to point connections on the same development 
machine, you must have different IP addresses for each connection. 

5. Click OK to accept these choices. 

The Network control property sheet appears. 

6. Click OK to exit the Network control property sheet. 

You are now ready to add the connection in MachineShop.  

Add Connection in MachineShop  
Once you have configured the TCP/IP properties for the Ethernet card, you can add the 
connection in MachineShop. 

To add an ethernet point to point connection in MachineShop, complete the following steps: 

1. Open MachineShop. 

2. Select the Add Connection command from the Transfer menu. 

      The New Connection dialog box appears. 

 

 

 

3. Enter a name for this connection. 

4. Select MachineShop Net (Serial/LAN) as the connection type. 

5. Click OK to accept these choices. 

      The New Connection Wizard appears. 
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6. Select LAN as the network connection type. 

7. Select Define runtime system now and then click Details to define the specific 
parameters for the target runtime system. 

8. The Network Details dialog box appears. 

 

 

 

 

 

 

 

9. Select IP Address and then enter the IP address of the runtime system in the top box of 
the Name group. 

      Typically the IP address for the runtime system is 10.0.0.2. 

      Click OK to accept your entries and return to the New Connection Wizard. 

10. Click Next to continue. 

      The following window appears. 
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11. Enter a user name and password only if an FTP user name and password was entered on 
the runtime system.  

12. The user name and password must match what was entered on the runtime system using 
the MachineShop Shell/Settings/FTP commands for you to gain access to the runtime 
system. 

      Click Finish to create the connection. 

13. Connect the development system to the Ethernet connector using a cross-over 10Base-T 
cable. 

You are now ready to transfer projects that you create in MachineShop to a runtime system. See 
Chapter 3 for details on creating projects and Chapter 6 for details on transferring files. 

If you need to make changes to the connection simply select the Edit Command from the Transfer 
menu. 

MachineShop Net PPP Connection 
Using the MachineShop Net Point to Point connection you can connect the development system 
to a runtime system using a serial cable with hardware handshaking. MachineShop uses a specific 
dial-up entry named “MachineShop Phonebook Entry” to communicate with the runtime system. 
The MachineShop Phonebook Entry is created when you install MachineShop. For details on the 
MachineShop installation program, see the MachineShop Installation Booklet.  

To add a Net Point to Point connection in MachineShop, complete the following steps: 

1. Open MachineShop. 

2. Select the Add Connection command from the Transfer menu or click the Add Connection 
button on the toolbar. 

The New Connection dialog box appears. 
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3. Enter a name for this connection. 

4. Select MachineShop Net (Serial/LAN) as the connection type. 

5. Click OK to accept these choices. 

The New Connection Wizard appears. 

 

 

 

 

 

 

 

 

6. Select PPP Serial as the network connection type. 

 Note This option uses a specific dial-up entry named “MachineShop Phonebook Entry”. This entry 
should have been created by the MachineShop installation program.  

  If the installation program could not create the MachineShop Phonebook Entry, the Direct 
Connection option will not be available. See Appendix A for instructions on how to manually 
create the MachineShop Phonebook Entry.  

7.    Select Define runtime system now and then click Details to define the specific parameters 
for the target runtime system. 

The Network Details dialog box appears. 
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8. Select IP Address and then enter the IP address of the runtime system in the top box of the 
Name group. 

Typically the IP address for the runtime system is 10.0.0.2. 

9. Click OK to accept these choices. 

You are returned to the New Connection Wizard. 

10. Click Next to continue. 

The following window appears.  

 

 

 

 

 

 

 

 

 

11. Enter a user name and password only if an FTP user name and password was entered on the 
runtime system.  

The user name and password must match what was entered on the runtime system using the 
MachineShop Shell/Settings/FTP commands for you to gain access to the runtime system. 

12. Click Finish to create the connection. 

13. Connect the serial cable to the appropriate serial port of the development system. 

You are now ready to transfer projects that you create in MachineShop to a runtime system. See 
Chapter 3 for details on creating projects and Chapter 6 for details on transferring files. 

If you need to make changes to the connection simply select the Edit Command from the Transfer 
menu. 

 

 41



 

Modem Connection 
The MachineShop Net Connection also allows a remote computer to connect to a runtime system 
through a modem. This connection uses Windows Dial-Up Networking to dial into a LAN-based 
remote access server.  

You must configure Dial-Up Networking in order to dial into the remote access server. Dial-Up 
Networking is available from the My Computer icon on the Windows desktop. Once you have 
created and configured the dial-up connection, you can add the connection in MachineShop.  

To add a modem connection in MachineShop, complete the following steps: 

1. Open MachineShop. 

2. Select the Add Connection command from the Transfer menu or click the Add Connection 
button on the toolbar. 

The New Connection dialog box appears. 

 

 

 

 

 

 

3. Enter a name for this connection. 

4. Select MachineShop Net (Serial/LAN) as the connection type. 

5. Click OK to accept these choices. 

The New Connection Wizard appears. 
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6. Select Dial-Up Networking as the network connection type and then select the dial-up entry 
from the list box. 

The list box displays the available dial-up entries that you can associated with this 
connection. These entries are created using Windows Dial-Up Networking available from the 
My Computer icon on the Windows desktop. See Appendix A for instructions on creating and 
configuring a MachineShop dial-up connection . 

7.    Select Define runtime system now and then click Details to define the specific parameters 
for the target runtime system. 

The Network Details dialog box appears. 

 

 

 

 

 

 

 

8. Select IP Address and then enter the IP address of the runtime system in the top box of the 
Name group. 

This is the IP address of the runtime system assigned by the network. Check with your local 
network administrator to determine a valid IP Address to be used on your local network. 

9. Click OK to accept your entries. 

You are returned to the New Connection Wizard. 

10. Click Next to continue. 

The following window appears. 
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11. Enter a user name and password only if an FTP user name and password was entered on the 
runtime system.  

The user name and password must match what was entered on the runtime system using the 
MachineShop Shell/Settings/FTP commands for you to gain access to the runtime system. 

12. Select Yes to enable passive transfers. Otherwise, select No. 

Passive transfers allow MachineShop to connect to an FTP server when the MachineShop 
Toolbar is behind a firewall. In most cases, you will NOT need passive transfers. 

13. Click Finish to create the connection. 

You are now ready to transfer projects that you create in MachineShop to a runtime system. See 
Chapter 3 for details on creating projects and Chapter 6 for details on transferring files. 

If you need to make changes to the connection simply select the Edit Command from the Transfer 
menu. 

IPM Compatible Connection 
The Interact IPM Compatible Serial connection is used to transfer projects to a Parker 
PowerStation that has the PowerStation Shell installed on it. This connection supports the transfer 
of Interact projects only, and is supplied for backward compatibility with existing systems. The 
Interact IPM Compatible connection uses a serial port connection between the MachineShop 
development system and the PowerStation. 

 Note This connection replaces IPM connectivity. IPM is a DOS based utility that is optimized for 
handling serial ports and the transfer of files through them. This connection will provide the 
same capability as IPM.  
Due to the addition of overhead in handling of serial ports in the Windows environment, the 
length of time necessary to transfer files with this connection may increase from the transfer 
times when using IPM. 

To add an Interact IPM Compatible connection, complete the following steps: 

1. Open MachineShop. 

2. Select the Add Connection command from the Transfer menu or click the Add 
Connection button on the toolbar. 

3. The New Connection dialog appears. 
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4. Enter a name for this connection. 

5. Select IPM Compatible (Serial) as the connection type. 

       Click OK to accept these choices. 

6. The New Connection Wizard appears. 

 

 

 

 

 

 

 

 

7. Select the COM port and baud rate you will be using in this connection. 

      Click Finish to create the connection. 

You are now ready to transfer Interact projects to a Parker PowerStation that has the 
PowerStation Shell installed on it. See Chapter 6 for details on transferring files. 

If you need to make changes to the connection simply select the Edit Command from the Transfer 
menu. 

Disk Transfer Connection 
Disk communications include communications between a development system and a mass 
storage device. Examples include internal and external hard drives, floppy drives, Zip drives, tape 
drives, network drives, Compact Flash readers, etc. The mass storage device must be mapped to a 
specific drive letter from A to Z. 

To add a disk transfer connection, complete the following steps: 

1. Open MachineShop 

2. Select the Add Connection command from the Transfer menu or click the Add Connection 
button on the toolbar. 
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The New Connection dialog box appears. 

 

 

 

 

 

3. Enter a name for this connection. 

4. Select Disk as the connection type. 
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5. Click OK to accept these choices. 

The New Connection Wizard appears. 

 

 

 

 

 

 

 

 

6. Select the letter of the drive you will be using in this connection. 

You may select any removable drive such as a floppy drive, Compact FLASH, or Zip drive. 

7. Click Finish to create the connection. 

You are now ready to transfer projects that you create in MachineShop to a runtime system. See 
Chapter 3 for details on creating projects and Chapter 6 for details on transferring files. 

If you need to make changes to the connection, simply select the Edit Connection command from 
the Transfer menu. 
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C h a p t e r  5  

Backing Up Projects  

MachineShop provides a wizard for backing up and restoring projects to and from runtime 
workstations or a variety of storage devices (diskette, Compact Flash, hard drive, network, etc.). 
This chapter describes how to create and restore a project backup for a current project or a project 
located on a runtime system. It contains both descriptive information and step-by-step 
instructions. 

Chapter Contents  
Creating a Backup 49  

Restoring a Backup 52
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Creating a Backup 
MachineShop provides a Backup Wizard to guide you through the process of backing up a local 
project or a project on a runtime system to a selected target. The target can be a variety of storage 
devices including diskette, Compact Flash, hard drive, or network.  

Projects are compressed into a subdirectory with the same name as the project. After the project is 
backed up, the file names are appended with a .zip suffix. 

Local Project Backup 
You may backup the current project on the development system using the Project command from 
the Create Backup submenu. This command will launch the Backup Wizard. 

To backup a local project, complete the following steps: 

1. Open the project if you haven’t already. 

2. Select the Create Backup command from the Tools menu. 

The Create Backup submenu appears. 

3. Select the Project command from the Create Backup submenu. 

The Backup Wizard appears. 

 

 

 

 

 

 

 

 

4. Enter the full path including the drive letter where you want to store this backup. 
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5. Select the components that you want to include in the backup: 

• Runtime Program Files - includes the Interact   
runtime program files. 

• Application Files - includes the Interact application files in the backup. 

6. Click Finish. 

The Backup Project Information window appears. 

 

 

 

 

 

 

 

 

 

7. Click OK to backup the active project on the development system. 

The Backing Up dialog box appears. 

8. Click Close when the backup operation is done. 

Remote Project Backup 

You may backup an active project on a runtime system using the Remote System command from 
the Create Backup submenu. This command will launch the Backup Wizard. 

 Note You must create the connection you plan to use to communicate with the runtime system 
before you can create the remote project backup. See Chapter 4 for information on adding 
connections. 

Important You can only back up projects on the runtime system when the MachineShop Shell’s Main 
Menu is displayed on the screen. 
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To backup a project on a runtime system, complete the following steps: 

1. Select the connection you want to use from the Select Connection box on the 
MachineShop Toolbar. 

2. Select the Create Backup command from the Tools menu. 

      The Create Backup submenu appears. 

3. Select the Remote System command from the Create Backup submenu. 

      The Backup Wizard appears. 

 

 

 

 

 

 

 

 

4. Enter the full path including the drive letter where you want to store this backup. 

5. Select the components that you want to include in the backup:  

      Runtime Program Files - includes the Interact and  
      runtime program files. 

6. Application Files - includes the Interact application files in the backup. 

      Click Finish to backup up the project on the runtime system. 

7. The Transferring dialog appears. It displays the current file being transferred, the 
direction, and the estimated time remaining in the transfer. 

      Click Close when the backup operation is done. 
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Restoring a Backup 
MachineShop provides a Restore Wizard to guide you through the process of restoring a project 
backup to either the development or runtime system. The backup may be located on a variety of 
storage devices including diskette, Compact Flash, hard drive, or network. 

Restore Backup to the Local System 
You may restore a project from a selected source to the development system using the Project 
command from the Restore Backup submenu. This command will launch the Restore Wizard. 
The Restore Wizard will automatically decompress the backup and restore it to the location set in 
the Project Path dialog box. 

To restore a project backup to the development system, complete the following steps: 

1. Select the Restore Backup command from the Tools menu. 

      The Restore Backup submenu appears. 

2. Select the Project command from the Restore Backup submenu. 

      The Restore Wizard appears. 

 

 

 

 

 

 

 

 

3. Enter the full path including the drive letter where the backup is stored. 

4. Select the project you want to restore from the list of project backups. 
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      Click Next. 

5. The following window appears. 

 

 

 

 

 

 

 

 

      Select the components of the project that you want to include in the restoration and then      
click Finish. 

6. The Restore Project Information window appears. 

 

 

 

 

 

 

 

      Click OK to restore the project on the development system. 

7. The Restore dialog box appears. 

NoteIf there is a current project with the same name as the project backup, the Restore Project dialog 
box appears. The Restoration process will delete the current project before it restores the backup. To 
continue the restoration process, click Restore. To rename the current project first, click Rename, or 
to exit the restoration process, click Cancel. 

8. Click Close when the restore operation is done.  
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Restore Project to a Remote System 
You may restore a project backup from a selected source to a runtime system using the Remote 
System command from the Restore Backup submenu. This command will launch the Restore 
Wizard. The Restore Wizard will automatically decompress the project backup and load it on the 
runtime workstation. 

Important You can only restore backup projects to the runtime system when the MachineShop Shell’s 
Main Menu is displayed on the screen. 

 Note You must create the connection you plan to use to communicate with the runtime system 
before you can restore a project to it. See Chapter 4 for information on adding connections. 

To restore a project backup to a runtime system, complete the following steps: 

1. Select the connection you plan to use from Select Connection box on the MachineShop 
Toolbar.  

2. Select the Restore Backup command from the Tools menu. 

The Restore Backup submenu appears. 

3. Select the Remote System command from the Restore Backup submenu. 

The Restore Wizard appears. 

 

 

 

 

 

 

 

 

4. Enter the full path including the drive letter where the backup is stored. 

5. Select the project you want to restore from the list of project backups. 
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6. Click Next. 

The following window appears. 

 

 

 

 

 

 

 

 

7. Select the components of the project that you want to include in the restoration and then click 
Finish. 

The Restore Remote Information window appears. 

 

 

 

 

 

 

 

 

8. Click OK to restore the project on the runtime system. 

The Transferring dialog box appears on the screen. It displays the current file being 
transferred, the direction, and the estimated time remaining in the transfer. 

9. Click Close when the restore operation is done. 
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C h a p t e r  6  

Transferr ing Projects  

Once an application has been developed and a connection created, you can transfer the files 
needed to create or update a runtime system. MachineShop provides a Transfer Wizard to step 
you through the process of selecting a connection and transferring the files to and from a runtime 
system.  

This chapter provides instructions on how to download and upload an active project from the 
development system to a runtime system. This includes using the Transfer Wizard and the 
Download and Upload commands. 

Chapter Contents  
Downloading a Project 57  

Uploading a Project 60
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Downloading a Project 
Downloading refers to the process of transferring project files from a development system to a 
runtime system. There are two ways to download files in MachineShop: the Transfer Wizard and 
the Download command. This section describes how to use the two methods to download files to 
the runtime system. 

Important You can only download project files to a runtime system when the MachineShop Shell’s Main 
Menu is displayed on the screen. 

Transfer Wizard 
The Transfer Wizard steps you through the process of selecting the transfer connection and 
downloading the project files to a runtime system.  

To download a project to a runtime system using the Transfer Wizard, complete the 
following steps: 

1. Open the project if you haven’t already. 

2. Select the Transfer Wizard command from the Transfer menu. 

The Transfer Wizard appears. 

 

 

 

 

 

 

 

 

3. Select Download to Runtime to download the project to the runtime system. 

4. Click Next to continue. 

5. Select the connection you want to use to transfer the files from the list of connections. 
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You may also create a connection from here. Click Define New Connection and follow the 
instructions provided by the New Connection Wizard. See Chapter 4 for more information on 
how to add a new connection. 

 Note You now have the option of having a direct serial connection, called MachineShop Direct 
Serial. 

6. Click Next to continue. 

The following window appears. 

 

 

 

 

 

 

 

 

7. Select Complete Project to download the entire project to the runtime system.  

If you do not want to download the entire project, clear the Complete Project check box; then 
select the files you want to download from the Components group box. 

8. Select Reboot from the drop down menu to reboot the runtime workstation after the 
download. Select No Reboot if you do not want to reboot the runtime workstation after the 
download. 

9. Select All Files to download all files or Update Files Only to download only the files that 
have changed since the last download. 

10. Click Finish to download the project files to the runtime system. 

 58 



 

The Transferring dialog appears. It displays the file being transferred, the direction of the transfer, 
and the estimated time remaining. 

Download Command  
You can also use the Download command to download project files on the development system 
to a runtime system.  

 Note You must create the connection you plan to use to communicate with the runtime system 
before you can use the Download command. See Chapter 4 for information on adding 
connections. 

To download a project to the runtime system using the Download command, complete the 
following steps: 

1. Open the project if you haven’t already. 

2. Select the connection you want to use to transfer the files from the Select Connection box on 
the toolbar. 

3. Select the Download command from the Transfer menu or click the Download button on the 
toolbar.  

The Download dialog box appears. 

 

 

 

 

 

 

 

 

 

 

4. Select Complete Project to download the entire project to the runtime system.  
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If you do not want to download the entire project, clear the Complete Project check box; then 
select the files you want to download from the Components group box. 

5. Select All Files to download all of the files or Update Files Only to download only the files 
that have changed since the last download. 

6. Select Reboot from the drop down menu to reboot the runtime workstation after the 
download. Select No Reboot if you do not want to reboot the runtime workstation after the 
download. 

7. Click Download to download the project files to the runtime system. 

The Transferring dialog appears. It displays the current file being transferred, the direction, and 
the estimated time remaining in the transfer. 

Uploading a Project 
Uploading refers to the process of transferring a project from a runtime system to a development 
system. Like Downloading, there are two ways to upload files in MachineShop: the Transfer 
Wizard and the Upload command. This section describes how to use the two methods to upload 
project files from the runtime system. 

Important You can only upload project files from a runtime system when the MachineShop Shell’s Main 
Menu is displayed on the screen. 

Transfer Wizard 
The Transfer Wizards steps you through the process of selecting the transfer connection and 
uploading the project files from the runtime system. 

To upload a project from the runtime system using the Transfer Wizard, complete the following 
steps: 

1. Select the Transfer Wizard command from the Transfer menu. 

The Transfer Wizard appears. 
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2. Select Upload from Runtime to upload the project. 

3. Click Next to continue. 

The following window appears. 

 

 

 

 

 

 

 

 

4. Select the connection you want to use to transfer the files from the list of connections. 

Or click Define New Connection and follow the instructions provided.  

See Chapter 4 for more information on how to add a new connection. 

You now have the option of having a direct serial connection, called Direct Serial. 

5. Click Next to continue. 

6. The following window appears. 

 

 

 

 

 

 

 

 

7. Select Complete Project to upload the entire project to the runtime system.  
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If you do not want to upload the entire project, clear the Complete Project check box; then 
select the files you want to upload from the Components group box. 

8. Select All Files to upload all of the files or Update Files Only to upload only the files that 
have changed since the last upload. 

9. Click Finish to upload the project files from the runtime system. 

The Transferring dialog appears. It displays the current file being transferred, the direction, and 
the estimated time remaining in the transfer. 

Upload Command 
You may also use the Upload command to upload files from the runtime system to the 
development system.  

 Note You must create the connection you plan to use to communicate with the runtime system 
before you can use the Upload command. See Chapter 4 for information on adding 
connections. You now have the option of having a direct serial connection, called 
MachineShop Direct Serial. 

To upload a project from the runtime system using the Upload command, complete the 
following steps: 

1. Select the connection you plan to use to transfer the files from Select Connection box on the 
toolbar. 

2. Select the Upload command from the Transfer menu or click the Upload button on the 
toolbar. 

The Upload dialog box appears. 

 

 

 

 

 

 

 

3. Select Complete Project to upload the entire project to the runtime system.  

If you do not want to upload the entire project, clear the Complete Project check box; then 
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select the files you want to upload from the Components group box. 

4. Select All Files to upload all of the files or Update Files Only to upload only the files that 
have changed since the last upload. 

5. Click Upload to upload the project files from the runtime system. 

The Transferring dialog appears. It displays the current file being transferred, the direction, and 
the estimated time remaining in the transfer. 
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C h a p t e r  7  

Customizing MachineShop 

You may customize some of the basic MachineShop operations to suit your needs. This chapter 
describes how to add frequently used programs to MachineShop, set the visibility of 
MachineShop on the desktop, and reposition the toolbars. 

Chapter Contents  
Set the Visibility 65  

Move the MachineShop Toolbars 66

Add, Edit, and Remove Suite Components 67
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Set the Visibility  
You may determine how MachineShop will appear on your desktop. You may have the 
MachineShop Toolbar visible at all times or you may have the toolbar automatically hide 
whenever the mouse pointer is outside the region occupied by the toolbar. 

You set the visibility options using the Options command from the Tools menu. 

To set the visibility of MachineShop, complete the following steps: 

1. Select the Options command from the Tools menu. 

The Options dialog box appears. 

 

 

 

 

 

2. Select Always on Top to keep MachineShop on top of all applications. 

 Note This option is checked by default and only available when the MachineShop Toolbar is 
undocked.  

3. Select AutoHide to hide MachineShop until you move the mouse into the region occupied by 
the MachineShop Toolbar. 

 Note This option is cleared by default and is only available when the MachineShop Toolbar is 
docked. 

4. Click OK to accept these choices. 
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Move the MachineShop Toolbars 
MachineShop is docked to the top of the Windows desktop by default. You may undock the 
toolbar by simply dragging it away from the edge. Once the toolbar is undocked, you can move it 
anywhere on the screen. 

To undock the MachineShop Toolbar, complete the following step: 

1. Position the mouse cursor over the MachineShop Toolbar. 

2. Click and drag the toolbar away from the edge of the Windows desktop. 

The toolbar appears as shown below. 

 

 

To dock the MachineShop Toolbar, complete the following steps: 

1. Position the mouse cursor over the MachineShop title bar. 

2. Click and drag the toolbar to the top of the Windows desktop. 

The toolbar snaps into place along the length of the screen edge. 

Move the MachineShop Rebars 
The MachineShop Toolbar includes three smaller toolbars called rebars. These rebars can be 
repositioned on the toolbar by clicking and dragging the small handlebars. 

 

 

To move the MachineShop rebars, complete the following steps: 

1. Position the mouse cursor over the handlebar of the rebar you want to move. 

2. Click and drag the rebar to the desired position. 
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Add, Edit, and Remove Suite Components  
You can add, edit, and remove frequently used programs to MachineShop. Once the program is 
added, you can then launch the program by clicking on the button on the MachineShop Toolbar, 
or by selecting the command from the Tools menu. 

This section describes how to add, edit, and remove programs from MachineShop.  

Add a Program  
You can add a program to MachineShop using the Add Suite Component command. After you 
add a program, you will be able to launch the program by clicking on a button on the 
MachineShop Toolbar or by selecting a command from the Tools menu. 

To add a program to MachineShop, complete the following steps: 

1. Select the Add Suite Component command from the Tools menu. 

The Add Suite Component dialog box appears. 

 

 

 

 

 

 

 

2. Browse to the location on your hard drive that contains the file you want to add. 

This can be any type of file, for example, an executable (.EXE) file, an Excel (.XLS) file, the 
configuration file for your I/O driver, etc. 

3. Click Open to accept this choice. 
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Edit a Program 
You can edit a program on the MachineShop toolbar using the Edit Suite Component command. 
By editing a program, you will be able to add the capability to pass the program a command line 
argument when the program launches. 

To edit a program on the MachineShop toolbar, complete the following steps: 

1. Select the Edit Suite Component command from the Tools menu. 

The Edit Suite Component dialog box appears. 

 

 

 

 

 

 

2. Highlight the icon for the suite component you want to edit. 

3. Select the Edit button. 

The Suite Component Properties dialog box appears. 

 

 

 

 

 

4. In the Command Line text box, enter a command line parameter that will be passed to the 
application when it is launched. 

5. Select the For this Project Only check box if you wish the button to be local to the current 
project. 
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Application buttons are global when first added to the Toolbar. The command line parameter 
will be stored in the current project’s .WMS file. 

6. Click OK to accept the selections. 

Remove a Program 
You can remove a program from the MachineShop that you previously added using the Add Suite 
Component command. MachineShop removes the associated button and menu command. 

To remove a program from MachineShop, complete the following steps: 

1. Select the Remove Suite Component command from the Tools menu. 

The Remove Suite Component dialog box appears. 

 

 

 

 

 

 

2. Select the icon for the program you want to remove. 

3. Click Remove to accept this choice. 
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Appendix A  

MachineShop Dial-Up Networking Connections 
This appendix describes how to create and configure dial-up networking connections for 
MachineShop. Configuration is necessary only for MachineShop Point-to-Point-Protocol.  

Note  Configuration is NOT required for MachineShop Direct Serial connection. 

Dial-Up Networking is available from the My Computer icon on the Windows desktop. 

 Note If you need to modify the TCP/IP settings or the modem’s baud rate for a dial-up 
connection, see the Configure the Connection sections in this appendix. Windows 95/98 
instructions start on  page 91,Windows NT instructions start on  page 97, and Windows 
2000 instructions start on  page 102. 

95/98 Dial-Up Networking 
This section describes the steps to create and configure a dial-up connection in Windows 95/98. 
See Windows NT Dial-Up Networking in this appendix for Windows NT instructions  page 95, 
and Windows 2000 Dial-Up Networking in this appendix for Windows 2000 instructions  page 
100. 

Create a Dial-Up Connection in Windows 95/98 
The connection stores the settings needed to connect to the runtime system.  

To create a dial-up connection in Windows 95/98, complete the following steps: 

1. Double-click the My Computer icon on the desktop and then double-click the Dial-Up 
Networking folder. 

      The Dial-Up Networking window appears. 
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2. Double-click the Make New Connection icon. 

      The Make a New Connection Wizard appears. 

 

 

 

 

 

        Enter the name of the computer you are dialing. 

 Important The name must be “MachineShop Phonebook Entry” if you are using the Direct 
Connection (Serial) option in MachineShop. 

3. Select MachineShop Direct Connection as the modem. 

4. Click Next. 

      The following window appears. 
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5. Enter “1” as the telephone number and then click Next. 

      The following window appears. 

 

 

 

 

 

 

6. Click Finish to save the phonebook entry. 

Configure the Connection in Windows 95/98 
Now you need to configure the newly created connection.  

To configure the connection, complete the following steps: 

1. Open Dial-Up Networking. 

The Dial-Up Networking window appears.  

 

 

 

 

 

Right click on the icon for the newly created connection and then select Properties. 

The property sheet for the selected connection appears. 
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3. Clear the Use area code and Dialing Properties check box on the General tab  

4. Click Configure to set the baud rate for the MachineShop Direct Connection. 

The MachineShop Direct Connection property window appears. 
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5. Select the speed that modem will use to transfer data from the maximum speed list.  

The default is 115200. This selection must match the baud rate set in the MachineShop 
Shell.  

 Note If you are have reliability problems using the selected speed, try selecting a slower speed. 

6. Click OK to accept these choices. 

The property sheet for the selected connection appears. 

7. Click the Server Types tab. 

The Server Types tab appears.  
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8. Clear all check boxes except the TCP/IP check box and then click TCP/IP Settings to 
configure the IP address. 

The TCP/IP Settings window appears.  

 

 

 

 

 

 

 

 

 

9. Select Specify an IP address and then enter the IP address for the development system. 

PARKER recommends that you enter 10.0.0.1 as the IP address for the development 
system. 

 Note If you are using both serial and Ethernet point to point connections on the same 
development machine, you must have different IP addresses for each connection. 

10. Select Specify name server addresses. 

Make sure all the addresses are set to 0.0.0.0. 

11. Clear the Use IP header compression and Use default gateway on remote network 
check boxes. 

12. Click OK to accept these choices. 

The property sheet for the selected connection appears. 

13. Click OK to exit the property sheet. 
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Windows NT Dial-Up Networking 
This section describes the steps to create and configure a dial-up connection in Windows NT. See 
Windows 95/98Dial-Up Networking in this appendix for Windows 95/98instructions  page 89, 
and Windows 2000 Dial-Up Networking in this appendix for Windows 2000 instructions  page 
100. 

Create a Dial-Up Connection in Windows NT 
The phonebook entry will store the settings needed to connect to the runtime system. The 
phonebook entry is created using Windows Dial-Up Networking. 

To create a phonebook entry in Windows NT, complete the following steps: 

1. Double-click the My Computer icon on the desktop and then double-click the Dial-Up 
Networking folder. 

2. If there are no previous phonebook entries, the message “The phonebook is empty” 
appears.  

 

 

 

 

 

 

 

NoteIf a phonebook entry already exists, the Dial-Up Networking window appears. Click New to add a 
new entry and skip to step 3. 

3. Click Yes to add an entry.  

             The New Phonebook Entry Wizard appears. 
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Important The name must be “MachineShop Phonebook Entry” if you are using the Direct 
Connection (Serial) option in MachineShop. 

 

4. Enter a name for the new phonebook entry and then click Next. 

      The Server window appears.  

 

 

 

 

 

 

 

 

 

5. Select Send my plain text password if that’s the only way to connect and then click Next. 

6. The Phone Number window appears. 
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7. Enter “1” as the phone number and then click Next. 

8. The New Phonebook Entry Wizard appears. 

9. Click Finish to save the phonebook entry. 

10. The Dial-Up Networking window appears with the new phonebook entry displayed in the 
Phonebook entry to dial box. 
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Configure the Connection in Windows NT 
Now you need to configure the phonebook entry. 

To configure the phonebook entry, complete the following steps: 

1. Open Dial-Up Networking. 

The Dial-Up Networking window appears. 

 

 

 

 

 

 

 

2. Select the phonebook entry from the Phonebook entry list.  

3. Click More and then select Edit entry and modem properties. 

The Edit Phonebook Entry property sheet appears. 
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4. Click Configure on the Basic tab to set the baud rate for the MachineShop Direct 
Connection. 

The Modem Configuration dialog box appears. 

 

 

 

 

 

 

5. Select the speed that modem will use to transfer data from the initial speed list. 

The default is 115200. This selection must match the baud rate set in the MachineShop 
Shell.  

 Note If you have reliability problems using the selected speed, try selecting a slower speed. 

6. Click OK. 

The Edit Phonebook Entry property sheet appears 

7. Click the Server tab. 

The Server tab appears. 
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8. Clear all check boxes except the TCP/IP check box and then click TCP/IP settings to 
configure the IP address. 

The TCP/IP Settings window appears. 

9. Select Specify an IP address and then enter the IP address for the development system. 

PARKER recommends that you enter 10.0.0.1 as the IP address for the development 
system. 

 Note If you are using both serial and Ethernet point to point connections on the same 
development machine, you must have different IP addresses for each connection. 

10. Select Specify name server addresses. 

Make sure all the addresses are set to 0.0.0.0. 

11. Clear the Use IP header compression and Use default gateway on remote network 
check boxes. 

12. Click OK to accept these choices. 

The Edit Phonebook Entry property sheet appears. 

13. Click OK to exit the Edit Phonebook Entry property sheet. 
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Windows 2000 Dial-Up Networking 
This section describes the steps to create and configure a dial-up connection in Windows 2000. 
See Windows NT Dial-Up Networking in this appendix for Windows NT instructions  page 95, 
and Windows 95/98 Dial-Up Networking in this appendix for Windows 95/98instructions  page 
89. 

Create a Dial-Up Connection in Windows 2000 
To create a phonebook entry in Windows 2000, complete the following steps: 

1. Double-click the My Computer icon on the desktop and then double-click the Control 
Panel folder and then double-click the Network and Dial-Up Connections folder. 

2. Double-click Make New Connection 

The Network Connection Wizard appears. 

3. Click Next. 

The Network Connection Type window appears. 
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4. Select Dial-up to private network. 

The Phone Number to Dial window 
appears:

 

5. Enter “1” as the phone number and then click Next. 

The Connection Availability window appears. 

6. Select For All Users and then click Next. 

The Completing the Network Connection window 
appears.
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7. Enter a name for the new phonebook entry and then click Finish. 

Important The name must be “MachineShop Phonebook Entry” if you are using the Direct 
Connection (Serial) option in MachineShop. 
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Configure the Connection in Windows 2000 
Now you need to configure the phonebook entry. 

To configure the phonebook entry, complete the following steps: 

1. Double-click the My Computer icon on the desktop and then double-click the Control 
Panel folder and then double-click the Network and Dial-Up Connections folder. 

The Network and Dial-Up Connections window 
appears.

 

2. Right click on the icon for the newly created connection and then select Properties. 

3. The property sheet for the selected connection appears. 
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4. Select Configure. 

The Modem Configuration dialog box appears. 

 

 

 

 

 

 

 

5. Select the Maximum speed (bps) that the modem will use to transfer data. 

The default is 115200. This selection must match the baud rate set in the MachineShop 
Shell.  

 Note If you have reliability problems using the selected speed, try selecting a slower speed. 

6. Click OK. 
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7. Click the Networking tab. 

The Networking tab appears. 

 

 

 

 

 

 

 

 

8. Clear all check boxes except the Internet Protocol (TCP/IP) check box and the Client 
for Microsoft Networks check box. Click on the Internet Protocol line, then click 
Properties to configure the IP address. 

The TCP/IP Properties window appears. 
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9. Select Use the following IP address and then enter the IP address for the development 
system. 

PARKER recommends that you enter 10.0.0.1 as the IP address for the development 
system. 

 Note If you are using both serial and Ethernet point to point connections on the same 
development machine, you must have different IP addresses for each connection. 

10. Leave the Use the following DNS server addresses blank. 

11. Click OK to accept these choices. 

The Edit Phonebook Entry property sheet appears. 

12. Click OK to exit the Edit Phonebook Entry property sheet. 
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Cable Pinouts 
This appendix describes the cable pinouts for a LAN cable, crossover cable, serial cable with 
handshaking, and a serial null modem cable with loopback. If you should decide to construct your 
own cable, refer the appropriate diagram below for assistance. 

10 Base-T, 
100 Base-T 

Ethernet LAN Cable Pinout 
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10 Base-T, 100 Base-T Ethernet Peer to Peer Crossover 
Cable 
Pinout
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MachineShop Serial PPP Cable with Hardware 
Handshaking 
Pinout
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MachineShop Serial PPP Null Modem Cable with 
Loopback 
Pinout
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